Visual Studio Ultimate French and WCF Load Test template

Dec 10, 2013 at 6:38 PM
Hi, I'm working in a french environement with VS 2010 Ultimate french edition. After WCF Load Test installation, i can't see WCF Load Test template in my C# test project. Only the command line tool is installed.

I tryed both version of WCF Load Test (3.0 et 4.0).

Does WCF Load test integration in Visual Studio supports other langage than english?

Thanks
Carl
Coordinator
Dec 10, 2013 at 10:43 PM
I don't think we ever tested it in another language, so I don't really know.

Having said that I have looked at the source and can't see a reason why it wouldn't work.

If you install from the command line and capture a setup log using the msiexec command that might help to see what could be going wrong.

Regards

Rob
Dec 12, 2013 at 3:20 PM
Edited Dec 12, 2013 at 9:35 PM
Hi Rob,

I found that WcfUnit10.zip is missing in "C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\ItemTemplates\CSharp\1036\" (VS 2010 utlimate french installation)

In a english setup, WcfUnit10.zip is prensent in "C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\ItemTemplates\CSharp\1033\"

I tried these commands to copy and install WcfUnit10.zip in the 1036 sub directory :
copy WcfUnit10.zip "%ProgramFiles%\Microsoft Visual Studio 10.0\Common7\IDE\ItemTemplates\CSharp\1036"
"%ProgramFiles%\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe" /installvstemplates
"%ProgramFiles%\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe" /setup

Wcf Load Test template is still missing in the new test panel.

Regards

Carl
Dec 12, 2013 at 9:48 PM
My mistake, these steps is working :

copy WcfUnit10.zip "%ProgramFiles%\Microsoft Visual Studio 10.0\Common7\IDE\ItemTemplates\CSharp\1036"
"%ProgramFiles%\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe" /installvstemplates
"%ProgramFiles%\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe" /setup


But installation file don't copy the WcfUnit10.zip in a non-english setup.


Thanks

Carl
Coordinator
Dec 13, 2013 at 5:45 PM
Hello Carl,

Thank you for your investigations. I have looked more closely and realised that you are right, it won't install correctly for non-English versions of Visual Studio. You can fix this by hand by copying the zip file to the correct location for your language which is:

Common7\IDE\ItemTemplates\CSharp\<number>

You then need to run the following commands which are normally run by the installer:

devenv/installvstemplates
devenv/setup

I hope this helps

Regards

Rob