WCF Load Test SOAP Actions

Apr 17, 2009 at 7:43 PM
After I point to my message trace file, click Parse, and click Next I am brought to the screen where I can select my SOAP Actions however nothing that I recognize is displayed.  All I see are http://schemas.xmlsoap.org/ws/2005/02/trust/RST/Issue and http://schemas.xmlsoap.org/ws/2005/02/trust/RSTR/Issue.  I do not know what these are and would have expected some reference to my Service Contract and/or Operation Contracts listed in here.
Coordinator
Apr 20, 2009 at 7:10 AM
These are something to do with a secure token service. Are you using a secure token service? For whatever reason it looks like your WCF messages simply did not get into the trace file. Make sure you have followed all the instructions in the Usage Notes document on how to set up the trace capture, also make sure that the client (if that is where you are tracing from) is cleanly shut down at the end of the run to make sure the data is flushed to the trace file. If all that fails please send me the trace file by contacting me through the People page.
May 4, 2009 at 12:45 PM
Yes I am using a secure token service however I am not sure how I did that.  Is there a way to undo the use of a secure token?  I looked at the trace file and verified that data is getting written to it when my service is running.  I compared the trace file with the one that was generated when I did the labs and I do see differences in the area where the messages are written to the trace file.  Is there a way to get the messages correctly written to the trace file despite using a secure token service?