"The trace file did not contain any usable data"

Jul 20, 2008 at 3:41 PM
Edited Jul 20, 2008 at 3:43 PM
I tried the wcfunit command-line-tool with a simple wcf-project (to be exact its just the sample-project that visual studio creates if you setup a new wcf-service-library project). I enabled the message logging on the service level and started the project to generate some entries in the message log. After that I tried to create the wcf load unit tests with the command-line tool. Unfortunately wcfunit gives me an error: "The trace file did not contain any usable data. Please make sure that LogMessageAtServiceLevel and LogEntireMessage are set"
Has anyone an idea what i am doing wrong?

ps: here is the message log:
<E2ETraceEvent xmlns="http://schemas.microsoft.com/2004/06/E2ETraceEvent">
  <System xmlns="http://schemas.microsoft.com/2004/06/windows/eventlog/system">
    <SubType Name="Information">0</SubType>
    <TimeCreated SystemTime="2008-07-20T15:18:56.3858460Z" />
    <Source Name="System.ServiceModel.MessageLogging" />
    <Correlation ActivityID="{00000000-0000-0000-0000-000000000000}" />
    <Execution ProcessName="WcfSvcHost" ProcessID="1352" ThreadID="8" />
        <MessageLogTraceRecord Time="2008-07-20T17:18:56.3858460+02:00" Source="ServiceLevelSendReply" Type="System.ServiceModel.Channels.BodyWriterMessage" xmlns="http://schemas.microsoft.com/2004/06/ServiceModel/Management/MessageTrace">
          <s:Envelope xmlns:a="http://www.w3.org/2005/08/addressing" xmlns:s="http://www.w3.org/2003/05/soap-envelope">
              <a:Action s:mustUnderstand="1">http://tempuri.org/IService1/GetDataResponse</a:Action>
              <GetDataResponse xmlns="http://tempuri.org/">
                <GetDataResult>You entered: 42</GetDataResult>

Jul 26, 2008 at 5:45 AM
This is likely to be a mismatch between the config file and the trace file. Try changing the clientTrace setting in the config file, or if you are using the wizard check the server-side option. Aplogies for the dealy in replying.