Could not find method for SOAP action "http://xxxxx", check that the right proxy assemblies have been supplied.

Sep 4, 2008 at 3:07 PM
Edited Sep 4, 2008 at 3:08 PM
Greetings,

I'm using the VS wizard and a pre-captured server-side trace file, but after selecting the correct assemblies and clicking Finish, I get a "Test Generation Error":

"Could not find method for SOAP action "http://xxxxx", check that the right proxy assemblies have been supplied."

Any suggestions would be greatly appreciated.
Coordinator
Sep 4, 2008 at 3:30 PM
I would need the information required to reproduce the problem, ideally the trace you are using and the assemblies you are referencing. I think you can contact me directly by clicking on my alias, we can then get in direct email contact to get traces etc.

Also, the tool does using System.Diagnostics.Trace so if you configure this in its config file you could send me the tool trace or see if it offers you any clues.
Sep 5, 2008 at 2:11 PM
Thanks for replying so quickly.

I was hoping it was just a bad config setting or something simple.

I can't send the files out of the building, but I'm working thru the Using.docx I found in the LAB folder.

Also, we're not explicitly setting the action using the Action= parameter on the OperationContract attribute.
Could this be a contributor to the issue?

Thanks for your help.
Coordinator
Sep 5, 2008 at 10:36 PM
I can understand that you can't send out any information, but it does make diagnosis rather more difficult. Can you give me any information at all about the contract? Could you send me perhaps the signature of the operation that is not working? I note that you are using a service-side trace, but the assemblies that you need to reference must contain either the contract or be client-side assemblies containing the proxy class.

It should not matter that you are not setting the Action parameter.

If you have not done so already, it really is a good idea to run through the lab first to get a feel for how it works, and to prove to yourself that it does actually work (!)

You could also run the command line version of the tool and configure it to create a trace to see if that offers any clues.
Sep 8, 2008 at 5:46 PM
Edited Sep 8, 2008 at 5:51 PM

I completed the lab and it worked fine.  Using a local dummy WCF service I was able to generate unit tests for the dummy methods and then include them in a VS load test which ran just fine.

For the real WCF service I'm referencing both the server-side assembly containing the contracts and the client-side assembly containing the proxies, is this correct?

I did notice these differences between the local SampleService which works and the WCF Server which is not:


SampleServiceEndpoint:

Address: http://...
Binding: BasicHttpBinding

 

MyEndpoint:
Address: net.tcp://...

Binding: NetTcpBinding

I'm still experimenting with the command line tool.

Coordinator
Sep 8, 2008 at 5:57 PM
The choice of protocol should not make a difference. It sounds like you are referencing the correct assemblies, in fact you only need to reference either the contracts assembly or the one with the proxies, try removing one of them.
Sep 9, 2008 at 10:34 PM
Edited Sep 10, 2008 at 7:04 PM
I removed them, moved them, added more of them, etc, no change.

I did discover by using svcutil.exe that the wsdl is unpublished.

Does this mean I should stop trying to use the server-side traces and the contracts assembly and focus on client-side traces, client config and the proxy assembly or will this prevent both trace files from being converted into unit tests?



Coordinator
Sep 16, 2008 at 3:52 PM
Only just seen your reply, for some reason I have stopped receiving notifications of new posts.

There is no reason why the fact that the WSDL is unpublished should prevent the tool working, whether on the client side or the proxy side. By all means try client-side, but there really should not be any difference.

To be able to help further I would need a repro that you can send me. I know you can't send the real files, but if you could reproduce the problem with something else; is this something you could do?
Sep 16, 2008 at 5:35 PM
I was getting the same error for both client and server side traces.  The wsdl is now being published but, as you just stated that has not resolved the issue.

I am unable to reproduce the issue using the lab examples, and a local WCF.  They work just fine.

I'll try to put the wcf lab examples on the test server and see if that will reproduce the problem.

I'll post again if I can get some clues.

Thanks for your help,